Degraded performance with Instrument Boards

Incident Report for NexusVC

Resolved

This incident has been resolved.
Posted Jun 17, 2022 - 11:26 EDT

Identified

We have identified an issue on our Instrument platform which may result in dashboard KPI's not reflecting live or accurate data. Don't worry our engineers are working to resolve the issue and we will post an update soon!
Posted Jun 17, 2022 - 11:25 EDT